#Azure – Easy fix to subscription is not registered to use microsoft.insights

Buy Me A Coffee

Hi!

Azure days for me and weird behavior when I was trying to enable some monitoring resources in an IoT Hub resource. In random times, I get an error similar to this one

The subscription ‘[subscription id]’ is not registered to use microsoft.insights.

And, it was weird because when I check the Resources providers available and registered for my subscription, the [microsoft.insights] appeared as [registered].

azure notifications displaying the monitoring microsoft insights issue

So, I tested a couple of reset scenarios, some other PowerShell scripts, and at the end the solution was the easiest one:

Unregister and Register again the provider.

5 minutes later, my monitoring capabilities were back available for me.

azure subscription resource provider

Again, it happened at random times, so there maybe an external factor also in this scenario.

Happy coding!

Greetings

El Bruno

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.