#AZURE Fix: #WebDeploy excluye algunos archivos al subir a Azure

Hola!

Desde hace 2 días estoy persiguiendo un error (que ahora me parece un poco tonto) relacionado con una CloudApp en Azure. Después de mucho revisar trazas y analizar comportamientos, llegué a la conclusión de que el problema estaba relacionado con los archivos que se estaban incluyendo en el paquete que se sube a Azure.

Cuando comencé a ver qué problemas tenía, me encontré con la falta de JQUERY, y claro a partir de allí muchas dependencias dejaban de funcionar.

Por suerte, los foros de MSDN y StackOverflow están llenos de gente con problemas y de referencias de ayuda creados por la comunidad. Uno de ellos me llevó a revisar la configuración de mi proyecto web, y en el mismo me encontré con que la opción “Items to deploy” no era la correcta.

Pues bien, seleccionando “All files in this Project folder” y desplegando nuevamente, mi problema terminó con una 😀

Importante: El 2do link que dejo debajo ha sido creado por Jason Lee hace unos años, gracias Jason!

Saludos @ Madrid

/El Bruno

References

– Stack Exchange, http://programmers.stackexchange.com/questions/198204/issue-deploying-asp-net-mvc-4-website-to-azure

– Excluding Files and Folders from Deployment, http://www.asp.net/web-forms/overview/deployment/advanced-enterprise-web-deployment/excluding-files-and-folders-from-deployment

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s