[#VS2012] Sobre el error raro de #LightSwitch for HTML Client Preview 2 y #ReSharper

image

Buenas,

hace unos días se liberó LightSwitch for HTML Client Preview 2 (el blog oficial aquí y el post aquí), como justo andaba necesitado de algo similar decidí probarlo. Antes del golpazo que me pegué pongo un poco de contexto, LightSwitch está bien. No muy bien, pero bien. En poco tiempo se pueden crear aplicaciones Data Driven que nos sacan de un apuro. Además la publicación en Azure es muy natural y claro, si tienes todo el paquete completo, puedes crear algo en modo demo o mantenimiento en pocos pasos.

Nota: Si piensas que LightSwitch solucionará todos tus problemas, pues estás frito, en una APLICACION REAL, no la típica demo o aplicación de usar y tirar, lo que creas en 15 minutos con LightSwitch no es suficiente, tienes que DEDICARLE MAS TIEMPO Y UN POCO DE SESERA. Ahí quedas advertido.

Como iba diciendo, la Client Preview 1 estaba solo disponible para probar en una máquina virtual, esta versión es más amigable y la podemos instalar como una extensión de Visual Studio 2012. Yo me fui a descargar la versión desde el link oficial y decidí probarla.

Sin embargo al momento de crear mi primer proyecto de prueba, me encontré con el siguiente error:

—————————
Microsoft Visual Studio
—————————
Cannot load the application item provider:\nSequence contains no elements\nThis may indicate the model file is corrupted.
—————————
OK  
—————————

image

Y listo!!! Visual Studio 2012 quedaba más frito que un huevo en pascua. Yo no soy de los que suelen pensar maquinaciones raras cuando algo no funciona, sin embargo esta vez todo me apuntaba a un plan maléfico para reventar una semana que viene siendo eterna … así que me armé de paciencia, comencé a buscar respuestas en internet y nada >> llegó el momento de depurar el IDE.

Nota 2: En mi caso cualquier excusa es buena para hacer un DUMP del IDE de Visual Studio 2012 y depurar cosillas a un nivel debajo de lo normal. No creo que mi búsqueda en BING haya tardado más de 2 segundos, porque he buscado de nuevo y he encontrado mi error reportado y solucionado.

Después de atacharme al IDE y de ver un poco las trazas del mismo, me di cuenta de que el problema estaba en que no hay amistad entre LightSwitch y ReSharper. Así que la solución más recomendable fue desactivar ReSharper desde el menú “Tool // Options” luego seleccionamos ReSharper y lo pausamos.

image

A partir de este momento LightSwitch comenzó a funcionar de perlas y pude seguir probando este new toy.

Descarga: http://go.microsoft.com/fwlink/?LinkID=255924

Forum: http://social.msdn.microsoft.com/Forums/en-US/lightswitchhtml/thread/5c7f5652-4712-4db7-8cd3-e9df4858d4a5

Saludos @ Home

El Bruno

image image image

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s